编程知识 购物 网址 新闻 笑话 | 软件 日历 阅读 图书馆 China
TxT小说阅读器
↓语音阅读,小说下载,古典文学↓
图片批量下载器
↓批量下载图片,美女图库↓
图片自动播放器
↓图片自动播放器↓
一键清除垃圾
↓轻轻一点,清除系统垃圾↓
vbs/VBScript DOS/BAT hta htc python perl 游戏相关 VBA 远程脚本 ColdFusion ruby专题 autoit seraphzone PowerShell linux shell Lua Golang Erlang 其它教程 CSS/HTML/Xhtml html5 CSS XML/XSLT Dreamweaver教程 经验交流
站长资讯 .NET新手 ASP.NET C# WinForm Silverlight WCF CLR WPF XNA VisualStudio ASP.NET-MVC .NET控件开发 EntityFramework WinRT-Metro Java C++ PHP Delphi Python Ruby C语言 Erlang Go Swift Scala R语言 Verilog 其它语言 架构设计 面向对象 设计模式 领域驱动 Html-Css JavaScript jQuery HTML5 SharePoint GIS技术 SAP OracleERP DynamicsCRM K2 BPM 信息安全 企业信息 Android开发 iOS开发 WindowsPhone WindowsMobile 其他手机 敏捷开发 项目管理 软件工程 SQLServer Oracle MySQL NoSQL 其它数据库 Windows7 WindowsServer Linux
   -> ruby专题 -> Windows下安装配置Ruby的debug工具ruby-debug-base19 -> 正文阅读

[ruby专题]Windows下安装配置Ruby的debug工具ruby-debug-base19

这篇文章主要介绍了Windows下安装配置Ruby的debug工具ruby-debug-base19的方法,同时讲解了Ruby的IDE RubyMine中的相关配置方法,需要的朋友可以参考下
gem使用代理的两种方式:
方式一: 

>>SET http_proxy=http://ip_or_host:PORT 
>>gem install the_package_name 


方式二: 

>>gem list -p http://user:passwd@ip_or_host:8080 -r 

安装ruby-debug-base19
有2种方法:
方法一:
先下载.gem文件,然后直接安装.gem文件,这种需要编译,所以需要带with-ruby-include参数,这个是ruby的开发编译包

>>curl -OL http://rubyforge.org/frs/download.php/75414/linecache19-0.5.13.gem  
>>curl -OL http://rubyforge.org/frs/download.php/75415/ruby-debug-base19-0.11.26.gem   
>>gem install linecache19-0.5.13.gem ruby-debug-base19-0.11.26.gem -- --with-ruby-include=$rvm_path/src/ruby-1.9.3-p125/  


方法二:
下载免编译的windows版本的ruby-debug.
最后使用代理安装ruby-debug-base19
复制代码 代码如下:
>>gem install ruby-debug-base19 -p http://ip_or_host:8080 -r -- --with-ruby-include=D:/ruby-1.9.3-p125/ 
gem 还可以查看远程的安装库包,以区别本地安装库

gem list -r 
gem install -r gem_package_name 


rubymine IDE中的配置
在rubymine中,如果ruby解释器选择的是1.9.3,那么调试时就必须安装ruby-debug-base19x,安装其他的都不行,即使是ruby-debug-base193,但是安装这个经常会报错。在大神网站stackoverflow.com上查找到答案。

curl -L "http://rubyforge.org/frs/download.php/75414/linecache19-0.5.13.gem" -o /tmp/linecache19-0.5.13.gem 
gem install linecache19-0.5.13.gem -- --with-ruby-include=D:\ruby-1.9.3-p125 
gem install ruby-debug-base19x -v 0.11.30.pre10 
gem install ruby-debug-ide -v 0.4.17.beta14 


如果还报错,那么就是卸载掉所有的ruby-debug-base版本,在重新安装.
在rubymine中,如果ruby解释器选择的是1.9.3,那么调试时就必须安装ruby-debug-base19x,安装其他的都不行,即使是ruby-debug-base193,但是安装这个经常会报错。在大神网站stackoverflow.com上查找到答案。

curl -L "http://rubyforge.org/frs/download.php/75414/linecache19-0.5.13.gem" -o /tmp/linecache19-0.5.13.gem 
gem install linecache19-0.5.13.gem -- --with-ruby-include=D:\ruby-1.9.3-p125 
gem install ruby-debug-base19x -v 0.11.30.pre10 
gem install ruby-debug-ide -v 0.4.17.beta14 


如果还报错,那么就是卸载掉所有的ruby-debug-base版本,在重新安装.
  ruby专题 最新文章
最新的CocoaPods安装教程
Rails实现字段加密存储
mac及linux下搭建ruby+rails环境
redis集群搭建教程及遇到的问题处理
ruby中并发并行与全局锁详解
Redis集群搭建全记录
Windows下安装配置Ruby的debug工具ruby-deb
使用Ruby实现FTP密码破解
Ruby中的public、private、protected区别小
Ruby实现网页图片抓取
上一篇文章      下一篇文章      查看所有文章
加:2016-11-09 22:54:50  更:2017-05-14 02:01:18 
 
360图书馆 软件开发资料 购物精选 新闻资讯 Chinese Culture 三丰软件 开发 中国文化 阅读网 日历 万年历 2019年12日历
2019-12-9 19:26:51
多播视频美女直播
↓电视,电影,美女直播,迅雷资源↓
TxT小说阅读器
↓语音阅读,小说下载,古典文学↓
一键清除垃圾
↓轻轻一点,清除系统垃圾↓
图片批量下载器
↓批量下载图片,美女图库↓
  网站联系: qq:121756557 email:121756557@qq.com  编程知识