IT数码 购物 网址 头条 软件 日历 阅读 图书馆
TxT小说阅读器
↓语音阅读,小说下载,古典文学↓
图片批量下载器
↓批量下载图片,美女图库↓
图片自动播放器
↓图片自动播放器↓
一键清除垃圾
↓轻轻一点,清除系统垃圾↓
开发: C++知识库 Java知识库 JavaScript Python PHP知识库 人工智能 区块链 大数据 移动开发 嵌入式 开发工具 数据结构与算法 开发测试 游戏开发 网络协议 系统运维
教程: HTML教程 CSS教程 JavaScript教程 Go语言教程 JQuery教程 VUE教程 VUE3教程 Bootstrap教程 SQL数据库教程 C语言教程 C++教程 Java教程 Python教程 Python3教程 C#教程
数码: 电脑 笔记本 显卡 显示器 固态硬盘 硬盘 耳机 手机 iphone vivo oppo 小米 华为 单反 装机 图拉丁
 
   -> C++知识库 -> PTA甲级 1088 Rational Arithmetic (C++) -> 正文阅读

[C++知识库]PTA甲级 1088 Rational Arithmetic (C++)

For two rational numbers, your task is to implement the basic arithmetics, that is, to calculate their sum, difference, product and quotient.

Input Specification:

Each input file contains one test case, which gives in one line the two rational numbers in the format a1/b1 a2/b2. The numerators and the denominators are all in the range of long int. If there is a negative sign, it must appear only in front of the numerator. The denominators are guaranteed to be non-zero numbers.

Output Specification:

For each test case, print in 4 lines the sum, difference, product and quotient of the two rational numbers, respectively. The format of each line is number1 operator number2 = result. Notice that all the rational numbers must be in their simplest form k a/b, where k is the integer part, and a/b is the simplest fraction part. If the number is negative, it must be included in a pair of parentheses. If the denominator in the division is zero, output Inf as the result. It is guaranteed that all the output integers are in the range of long int.

Sample Input 1:

2/3 -4/2

Sample Output 1:

2/3 + (-2) = (-1 1/3)
2/3 - (-2) = 2 2/3
2/3 * (-2) = (-1 1/3)
2/3 / (-2) = (-1/3)

Sample Input 2:

5/3 0/6

Sample Output 2:

1 2/3 + 0 = 1 2/3
1 2/3 - 0 = 1 2/3
1 2/3 * 0 = 0
1 2/3 / 0 = Inf

Solution:

// Talk is cheap, show me the code
// Created by Misdirection 2021-08-23 21:29:12
// All rights reserved.

#include <iostream>
#include <vector>
#include <cmath>
#include <algorithm>

using namespace std;

int gcd(long long a, long long b){
    if(a < b) swap(a, b);

    if(a % b == 0) return b;
    return gcd(b, a % b);
}

struct Num{
    long long numerator;
    long long denominator;

    Num(long long n, long long d){
        if(n == 0){
            numerator = 0;
            denominator = 1;
            return;
        }

        long long tmp = gcd(abs(n), d);

        numerator = n / tmp;
        denominator = d / tmp;
    }

    ~Num(){}
};

Num sum(Num &a, Num &b){
    long long numerator = a.numerator * b.denominator + a.denominator * b.numerator;
    long long denominator = a.denominator * b.denominator;

    Num ans(numerator, denominator);
    return ans;
}

Num difference(Num &a, Num &b){
    long long numerator = a.numerator * b.denominator - a.denominator * b.numerator;
    long long denominator = a.denominator * b.denominator;

    Num ans(numerator, denominator);
    return ans;
}

Num product(Num &a, Num &b){
    long long numerator = a.numerator * b.numerator;
    long long denominator = a.denominator * b.denominator;

    Num ans(numerator, denominator);
    return ans;
}

Num quotient(Num &a, Num &b){
    
    long long numerator = a.numerator * b.denominator;
    long long denominator = a.denominator * b.numerator;
    
    if(denominator < 0){
        numerator = -numerator;
        denominator = -denominator;
    }

    Num ans(numerator, denominator);
    return ans;
}

string numToString(Num &n){
    string ans = "";
    long long integer, fractional;

    if(n.denominator == 1) ans = to_string(n.numerator);
    else{
        if(abs(n.numerator) < n.denominator) ans = to_string(n.numerator) + "/" + to_string(n.denominator);
        else{
            integer = n.numerator / n.denominator;
            fractional = n.numerator % n.denominator;

            ans = to_string(integer) + " " + to_string(abs(fractional)) + "/" + to_string(n.denominator); 
        } 
    }
    if(ans[0] == '-') ans = "(" + ans + ")";

    return ans;
}

int main(){
    int an, ad, bn, bd;
    int integer, fractional;
    scanf("%d/%d %d/%d", &an, &ad, &bn, &bd);

    Num n1((long long)an, (long long)ad), n2((long long)bn, (long long)bd);
    string n3, n4, ans;
    
    n3 = numToString(n1);
    n4 = numToString(n2);

    Num ans1 = sum(n1, n2);
    ans = numToString(ans1);
    printf("%s + %s = %s\n", n3.c_str(), n4.c_str(), ans.c_str());

    Num ans2 = difference(n1, n2);
    ans = numToString(ans2);
    printf("%s - %s = %s\n", n3.c_str(), n4.c_str(), ans.c_str());

    Num ans3 = product(n1, n2);
    ans = numToString(ans3);
    printf("%s * %s = %s\n", n3.c_str(), n4.c_str(), ans.c_str());

    if(n2.numerator == 0) printf("%s / %s = Inf\n", n3.c_str(), n4.c_str());
    else{
        Num ans4 = quotient(n1, n2);
        ans = numToString(ans4);
        printf("%s / %s = %s\n", n3.c_str(), n4.c_str(), ans.c_str());
    }
    

    return 0;
}

在这里插入图片描述

  C++知识库 最新文章
【C++】友元、嵌套类、异常、RTTI、类型转换
通讯录的思路与实现(C语言)
C++PrimerPlus 第七章 函数-C++的编程模块(
Problem C: 算法9-9~9-12:平衡二叉树的基本
MSVC C++ UTF-8编程
C++进阶 多态原理
简单string类c++实现
我的年度总结
【C语言】以深厚地基筑伟岸高楼-基础篇(六
c语言常见错误合集
上一篇文章      下一篇文章      查看所有文章
加:2021-08-24 15:22:34  更:2021-08-24 15:23:41 
 
开发: C++知识库 Java知识库 JavaScript Python PHP知识库 人工智能 区块链 大数据 移动开发 嵌入式 开发工具 数据结构与算法 开发测试 游戏开发 网络协议 系统运维
教程: HTML教程 CSS教程 JavaScript教程 Go语言教程 JQuery教程 VUE教程 VUE3教程 Bootstrap教程 SQL数据库教程 C语言教程 C++教程 Java教程 Python教程 Python3教程 C#教程
数码: 电脑 笔记本 显卡 显示器 固态硬盘 硬盘 耳机 手机 iphone vivo oppo 小米 华为 单反 装机 图拉丁

360图书馆 购物 三丰科技 阅读网 日历 万年历 2024年6日历 -2024/6/3 15:31:28-

图片自动播放器
↓图片自动播放器↓
TxT小说阅读器
↓语音阅读,小说下载,古典文学↓
一键清除垃圾
↓轻轻一点,清除系统垃圾↓
图片批量下载器
↓批量下载图片,美女图库↓
  网站联系: qq:121756557 email:121756557@qq.com  IT数码