IT数码 购物 网址 头条 软件 日历 阅读 图书馆
TxT小说阅读器
↓语音阅读,小说下载,古典文学↓
图片批量下载器
↓批量下载图片,美女图库↓
图片自动播放器
↓图片自动播放器↓
一键清除垃圾
↓轻轻一点,清除系统垃圾↓
开发: C++知识库 Java知识库 JavaScript Python PHP知识库 人工智能 区块链 大数据 移动开发 嵌入式 开发工具 数据结构与算法 开发测试 游戏开发 网络协议 系统运维
教程: HTML教程 CSS教程 JavaScript教程 Go语言教程 JQuery教程 VUE教程 VUE3教程 Bootstrap教程 SQL数据库教程 C语言教程 C++教程 Java教程 Python教程 Python3教程 C#教程
数码: 电脑 笔记本 显卡 显示器 固态硬盘 硬盘 耳机 手机 iphone vivo oppo 小米 华为 单反 装机 图拉丁
 
   -> C++知识库 -> PTA 7-1 猜数列游戏2-1 (10 分) -> 正文阅读

[C++知识库]PTA 7-1 猜数列游戏2-1 (10 分)

在猜数列游戏1的基础上,设置一个数组用来存放6个数列的第2到第4个数,在用户要求猜测新数列的情况下,循环显示各数列的前两个数,要求用户猜测第3个数。 6个数列3个组成的数组为:{1,2,3,3,4,7,2,5,12,3,6,10,4,9,16,5,12,22}

输入格式:

根据要求输入整数数值为字符Y或N

输出格式:

各提示信息与猜数列游戏1一致。

输入样例:

在这里给出一组输入。例如:

3
Y
7
Y
12
Y
10
Y
16
Y
22
Y
5
Y
3
N

输出样例:

在这里给出相应的输出。例如:

The first 2 value is 1,2.What is the next value?
Want to try another sequence?(Y/N)
The first 2 value is 3,4.What is the next value?
Want to try another sequence?(Y/N)
The first 2 value is 2,5.What is the next value?
Want to try another sequence?(Y/N)
The first 2 value is 3,6.What is the next value?
Want to try another sequence?(Y/N)
The first 2 value is 4,9.What is the next value?
Want to try another sequence?(Y/N)
The first 2 value is 5,12.What is the next value?
Want to try another sequence?(Y/N)
The first 2 value is 1,2.What is the next value?
Nice guess but not quite it.
Do you want to guess again?
Want to try another sequence?(Y/N)
num_of_rights:7 num_of_tries:8

代码实现(C++)

#include <iostream>
#include <cstdio>
using namespace std;

int main()
{
	int a1=3,a2=5,i=0,num,sum_t=0,sum_Y=0;
	int a[18]={1,2,3,3,4,7,2,5,12,3,6,10,4,9,16,5,12,22};
	int count=0; 
	char ch,ch2;
	bool go1=true,go2=true;
	while(1)
	{	
		if(i<1)
            cout << "The first 2 value is " << a[count] << ',' << a[count+1] << ".What is the next value?" << endl;
        i++;    
		if(i<=100&&i>=1)	
			cin >> num;
		while(1)
		{
			if(num!=a[count+2]&&i==1)
			{	
                printf("Nice guess but not quite it.\n");
				sum_t++;
			}
			if(num!=a[count+2]&&i==2)	
			{
                printf("Wrong a second time.\n");
				sum_t++;
			}
			if(num!=a[count+2]&&i==3)
			{
                printf("This is harder than it looks.\n");
				sum_t++;
			}
			if(num!=a[count+2]&&i==4)
			{
				sum_t++;
                printf("It must be getting pretty frustrating by now!\n");
                
			}
			if(num!=a[count+2])
			{
				printf("Do you want to guess again?\n");	
				cin >> ch2;
				if(ch2=='Y')
				{
					break;
				}
			} 
			if(num == a[count+2]||ch2=='N')
			{	
				i=0;
				if(num==a[count+2])
				{
					sum_Y++;
					sum_t++;
				}
                printf("Want to try another sequence?(Y/N)\n");
                if(count<15)
                {
                	count+=3;
				}
				else count=0;
				cin >> ch;
				if(ch == 'Y')
					break;
				else
				{
					printf("num_of_rights:%d num_of_tries:%d",sum_Y,sum_t);
					exit(0);
				} 
			}
		}
	}
	return 0;
}

  C++知识库 最新文章
【C++】友元、嵌套类、异常、RTTI、类型转换
通讯录的思路与实现(C语言)
C++PrimerPlus 第七章 函数-C++的编程模块(
Problem C: 算法9-9~9-12:平衡二叉树的基本
MSVC C++ UTF-8编程
C++进阶 多态原理
简单string类c++实现
我的年度总结
【C语言】以深厚地基筑伟岸高楼-基础篇(六
c语言常见错误合集
上一篇文章      下一篇文章      查看所有文章
加:2021-09-22 14:29:00  更:2021-09-22 14:31:09 
 
开发: C++知识库 Java知识库 JavaScript Python PHP知识库 人工智能 区块链 大数据 移动开发 嵌入式 开发工具 数据结构与算法 开发测试 游戏开发 网络协议 系统运维
教程: HTML教程 CSS教程 JavaScript教程 Go语言教程 JQuery教程 VUE教程 VUE3教程 Bootstrap教程 SQL数据库教程 C语言教程 C++教程 Java教程 Python教程 Python3教程 C#教程
数码: 电脑 笔记本 显卡 显示器 固态硬盘 硬盘 耳机 手机 iphone vivo oppo 小米 华为 单反 装机 图拉丁

360图书馆 购物 三丰科技 阅读网 日历 万年历 2024年5日历 -2024/5/20 0:31:05-

图片自动播放器
↓图片自动播放器↓
TxT小说阅读器
↓语音阅读,小说下载,古典文学↓
一键清除垃圾
↓轻轻一点,清除系统垃圾↓
图片批量下载器
↓批量下载图片,美女图库↓
  网站联系: qq:121756557 email:121756557@qq.com  IT数码