IT数码 购物 网址 头条 软件 日历 阅读 图书馆
TxT小说阅读器
↓语音阅读,小说下载,古典文学↓
图片批量下载器
↓批量下载图片,美女图库↓
图片自动播放器
↓图片自动播放器↓
一键清除垃圾
↓轻轻一点,清除系统垃圾↓
开发: C++知识库 Java知识库 JavaScript Python PHP知识库 人工智能 区块链 大数据 移动开发 嵌入式 开发工具 数据结构与算法 开发测试 游戏开发 网络协议 系统运维
教程: HTML教程 CSS教程 JavaScript教程 Go语言教程 JQuery教程 VUE教程 VUE3教程 Bootstrap教程 SQL数据库教程 C语言教程 C++教程 Java教程 Python教程 Python3教程 C#教程
数码: 电脑 笔记本 显卡 显示器 固态硬盘 硬盘 耳机 手机 iphone vivo oppo 小米 华为 单反 装机 图拉丁
 
   -> C++知识库 -> PAT甲级1022 C++ -> 正文阅读

[C++知识库]PAT甲级1022 C++

PAT甲级1022

题目描述

A Digital Library contains millions of books, stored according to their titles, authors, key words of their abstracts, publishers, and published years. Each book is assigned an unique 7-digit number as its ID. Given any query from a reader, you are supposed to output the resulting books, sorted in increasing order of their ID’s.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N N N ( ≤ 1 0 4 ≤10^4 104) which is the total number of books. Then N N N blocks follow, each contains the information of a book in 6 lines:

  • Line #1: the 7-digit ID number;
  • Line #2: the book title – a string of no more than 80 characters;
  • Line #3: the author – a string of no more than 80 characters;
  • Line #4: the key words – each word is a string of no more than 10 characters without any white space, and the keywords are separated by
    exactly one space;
  • Line #5: the publisher – a string of no more than 80 characters;
  • Line #6: the published year – a 4-digit number which is in the range [ 1000 , 3000 ] [1000, 3000] [1000,3000].

It is assumed that each book belongs to one author only, and contains no more than 5 key words; there are no more than 1000 distinct key words in total; and there are no more than 1000 distinct publishers.

After the book information, there is a line containing a positive integer M ( ≤ 1000 ) M (≤1000) M(1000) which is the number of user’s search queries. Then M M M lines follow, each in one of the formats shown below:

  • 1: a book title
  • 2: name of an author
  • 3: a key word
  • 4: name of a publisher
  • 5: a 4-digit number representing the year

Output Specification:

For each query, first print the original query in a line, then output the resulting book ID’s in increasing order, each occupying a line. If no book is found, print Not Found instead.

Sample Input:

3
1111111
The Testing Book
Yue Chen
test code debug sort keywords
ZUCS Print
2011
3333333
Another Testing Book
Yue Chen
test code sort keywords
ZUCS Print2
2012
2222222
The Testing Book
CYLL
keywords debug book
ZUCS Print2
2011
6
1: The Testing Book
2: Yue Chen
3: keywords
4: ZUCS Print
5: 2011
3: blablabla

Sample Output:

1: The Testing Book
1111111
2222222
2: Yue Chen
1111111
3333333
3: keywords
1111111
2222222
3333333
4: ZUCS Print
1111111
5: 2011
1111111
2222222
3: blablabla
Not Found

思路分析

本题目的主要目的是根据输入来查找对应的ID,所以应该选择查找效率较高的数据结构。std::mapstd::set可以满足需求。因读入的是字符串,所以要用std::string作为std::map的键,鉴于keyword可以有多个,因此要用另外一个容器存储每一个keyword对应的ID,所以std::map的值类型应为std::set。这同样是为了提高查找效率。

注意点

  1. keyword要按空格分隔开,分隔开的每一个keyword都要映射到一个ID集合。
  2. 注意输出格式,ID为7位,此处将ID设为int,所以使用printf输出时,一定要用"%07d"格式化,否则测试点3、4不通过!
  3. 使用scanf读入ID后,一定要吸收换行符,否则std::getline会将换行读入。

C++ 程序

#include <iostream>
#include <map>
#include <set>
#include <string>

int main() {
    std::map<std::string, std::set<int>> mp[5];
    int n, m, p, id;
    std::string buf;
    scanf("%d", &n);
    for (int i = 0; i < n; ++i) {
        scanf("%d\n", &id);
        for (int j = 0; j < 5; ++j) {
            if (j == 2) {
                while (std::cin >> buf) {
                    mp[j][buf].insert(id);
                    if (std::cin.get() == '\n') break;
                }
            } else {
                std::getline(std::cin, buf);
                mp[j][buf].insert(id);
            }
        }
    }
    scanf("%d\n", &m);
    for (int i = 0; i < m; ++i) {
        scanf("%d: ", &p);
        std::getline(std::cin, buf);
        printf("%d: %s\n", p--, buf.c_str());
        if (mp[p].find(buf) == mp[p].end()) {
            printf("Not Found\n");
            continue;
        }
        for (auto& num : mp[p][buf]) {
            printf("%07d\n", num);
        }
    }
    return 0;
}

上面的程序中注意读入keyword时的处理。在此使用std::cin读入每一个keyword,因std::cin读入字符串是以空格或换行为结束标志的,所以自然达到了分隔字符串的目的。

  C++知识库 最新文章
【C++】友元、嵌套类、异常、RTTI、类型转换
通讯录的思路与实现(C语言)
C++PrimerPlus 第七章 函数-C++的编程模块(
Problem C: 算法9-9~9-12:平衡二叉树的基本
MSVC C++ UTF-8编程
C++进阶 多态原理
简单string类c++实现
我的年度总结
【C语言】以深厚地基筑伟岸高楼-基础篇(六
c语言常见错误合集
上一篇文章      下一篇文章      查看所有文章
加:2021-10-01 16:38:20  更:2021-10-01 16:39:17 
 
开发: C++知识库 Java知识库 JavaScript Python PHP知识库 人工智能 区块链 大数据 移动开发 嵌入式 开发工具 数据结构与算法 开发测试 游戏开发 网络协议 系统运维
教程: HTML教程 CSS教程 JavaScript教程 Go语言教程 JQuery教程 VUE教程 VUE3教程 Bootstrap教程 SQL数据库教程 C语言教程 C++教程 Java教程 Python教程 Python3教程 C#教程
数码: 电脑 笔记本 显卡 显示器 固态硬盘 硬盘 耳机 手机 iphone vivo oppo 小米 华为 单反 装机 图拉丁

360图书馆 购物 三丰科技 阅读网 日历 万年历 2024年5日历 -2024/5/19 20:01:39-

图片自动播放器
↓图片自动播放器↓
TxT小说阅读器
↓语音阅读,小说下载,古典文学↓
一键清除垃圾
↓轻轻一点,清除系统垃圾↓
图片批量下载器
↓批量下载图片,美女图库↓
  网站联系: qq:121756557 email:121756557@qq.com  IT数码