IT数码 购物 网址 头条 软件 日历 阅读 图书馆
TxT小说阅读器
↓语音阅读,小说下载,古典文学↓
图片批量下载器
↓批量下载图片,美女图库↓
图片自动播放器
↓图片自动播放器↓
一键清除垃圾
↓轻轻一点,清除系统垃圾↓
开发: C++知识库 Java知识库 JavaScript Python PHP知识库 人工智能 区块链 大数据 移动开发 嵌入式 开发工具 数据结构与算法 开发测试 游戏开发 网络协议 系统运维
教程: HTML教程 CSS教程 JavaScript教程 Go语言教程 JQuery教程 VUE教程 VUE3教程 Bootstrap教程 SQL数据库教程 C语言教程 C++教程 Java教程 Python教程 Python3教程 C#教程
数码: 电脑 笔记本 显卡 显示器 固态硬盘 硬盘 耳机 手机 iphone vivo oppo 小米 华为 单反 装机 图拉丁
 
   -> C++知识库 -> C++ Grand Garden | AtCoder -> 正文阅读

[C++知识库]C++ Grand Garden | AtCoder

Time Limit: 2 sec / Memory Limit: 1024 MB

Problem Statement

In a flower bed, there are?N?flowers, numbered 1,2,......,N. Initially, the heights of all flowers are?0. You are given a sequence?h={h1?,h2?,h3?,......}?as input. You would like to change the height of Flower?k?to hk??for all?k(1≤k≤N), by repeating the following "watering" operation:

  • Specify integers?l?and?r. Increase the height of Flower?x?by?1?for all?x?such that l≤x≤r.

Find the minimum number of watering operations required to satisfy the condition.

Constraints

  • 1≤N≤100
  • 0≤hi?≤100
  • All values in input are integers.

Input

Input is given from Standard Input in the following format:

N
h1? h2? h3? ............ hN?

Output

Print the minimum number of watering operations required to satisfy the condition.


Sample Input 1?

4
1 2 2 1

Sample Output 1?

2

The minimum number of watering operations required is?2. One way to achieve it is:

  • Perform the operation with (l,r)=(1,3).
  • Perform the operation with (l,r)=(2,4).

Sample Input 2?

5
3 1 2 3 1

Sample Output 2?

5

Sample Input 3?

8
4 23 75 0 23 96 50 100

Sample Output 3?

221

Solution:

#include<bits/stdc++.h>
using namespace std;
int n,h[105],l,r,g[105],cnt;
int main(){
	scanf("%d",&n);
	for(int i=1;i<=n;i++)scanf("%d",&h[i]);
	for(int i=1;i<=n;i++){
		for(int j=i;g[i]<h[i];j++){
			for(int k=i;h[k]!=g[k];k++){
				g[k]++;
			}
			cnt++;
		}
	}
	printf("%d",cnt);
	return 0;
}

  C++知识库 最新文章
【C++】友元、嵌套类、异常、RTTI、类型转换
通讯录的思路与实现(C语言)
C++PrimerPlus 第七章 函数-C++的编程模块(
Problem C: 算法9-9~9-12:平衡二叉树的基本
MSVC C++ UTF-8编程
C++进阶 多态原理
简单string类c++实现
我的年度总结
【C语言】以深厚地基筑伟岸高楼-基础篇(六
c语言常见错误合集
上一篇文章      下一篇文章      查看所有文章
加:2022-09-21 00:08:17  更:2022-09-21 00:12:13 
 
开发: C++知识库 Java知识库 JavaScript Python PHP知识库 人工智能 区块链 大数据 移动开发 嵌入式 开发工具 数据结构与算法 开发测试 游戏开发 网络协议 系统运维
教程: HTML教程 CSS教程 JavaScript教程 Go语言教程 JQuery教程 VUE教程 VUE3教程 Bootstrap教程 SQL数据库教程 C语言教程 C++教程 Java教程 Python教程 Python3教程 C#教程
数码: 电脑 笔记本 显卡 显示器 固态硬盘 硬盘 耳机 手机 iphone vivo oppo 小米 华为 单反 装机 图拉丁

360图书馆 购物 三丰科技 阅读网 日历 万年历 2024年5日历 -2024/5/19 16:19:38-

图片自动播放器
↓图片自动播放器↓
TxT小说阅读器
↓语音阅读,小说下载,古典文学↓
一键清除垃圾
↓轻轻一点,清除系统垃圾↓
图片批量下载器
↓批量下载图片,美女图库↓
  网站联系: qq:121756557 email:121756557@qq.com  IT数码